Public Network - touching anything in IP change to Domain netword

Carlos Yohn Zubiría 41 Reputation points


Windows server 2023; Hyper-v host in a cluster with other server 2023

On premise active directory & Domain.

Two accesible DNS servers.

When we power-on the server, network appears as public; with internet access but public. Then, if i change IP adresss from to and return to the one, network becomes domain network. Also changing mask and returning to the original one; o adding a secondary ip; any change in Tcp-IP V4 protocolo gets domain network working fine.

Any idea?

Thanks in advance.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,285 questions
Windows Network
Windows Network
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.Network: A group of devices that communicate either wirelessly or via a physical connection.
667 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Wesley Li 5,325 Reputation points


    You mean the network is not identified as the correct category (domain network, public network, private network), right?

    If so, you don't need to worry. You can manually change the network category on Windows Server 2023.

    On the server desktop, right-click the "Start" button and select "Settings" or press Win + I to open the "Settings" app.

    Click "Network & Internet" -> "Status". You can see the currently active network adapter on the right side of the window. Click "Properties" on the network adapter you want to modify, and then you can determine the network profile for this network adapter.

    You can also use PowerShell's Set-NetConnectionProfile command to change the type of network connection if the graphical interface does not have the Settings.

    0 comments No comments