Enterprise Report Server not showing Data Driven Subscriptions

Linda 1 Reputation point
2024-04-29T21:26:46.1566667+00:00

We have updgraded from Standard to Enterprise reporting services. We were expecting to have the option to create data-driven subscriptions but the option is not available. All the articles found during our web search say 'Data-driven subscriptions' will just be available when you have an Enterprise license. We would appreciate help.

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,827 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. ZoeHui-MSFT 33,626 Reputation points
    2024-05-06T02:33:07.4266667+00:00

    Hi @Linda

    Please have a double check that data source connection information used by the report to get data.

    Only reports that use stored credentials to access a report data source can be distributed through a data-driven subscription. Stored credentials are necessary for unattended report processing.

    Regards,

    Zoe Hui


    If the answer is helpful, please click "Accept Answer" and upvote it.

    1 person found this answer helpful.

  2. LucyChenMSFT-4874 1,430 Reputation points
    2024-04-30T02:34:13.53+00:00

    Hi @Linda,

    Thanks for your information.

    but the option is not available

    Please ensure you have the Content Manager permissions. You can follow the steps below to grant permission:

    1. Open Reporting Services Configuration Manager.
    2. Select the Report Manager URL tab.
    3. In the Report Manager Site Identification section, select the URL to open Report Manager.
    4. Select Manage. 1

    Inked2_LI

    3

    Finally, this is an article explains how to create data-driven subscription in detail, you can check it out and follow the steps.

    Hope this can help you well. Feel free to share your issue here.

    Best regards,

    Lucy Chen


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our Documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    https://docs.microsoft.com/en-us/answers/support/email-notifications


  3. LucyChenMSFT-4874 1,430 Reputation points
    2024-05-09T09:17:47.17+00:00

    Hi @Linda,

    Thanks for your feedback.

    Please make sure you've correctly configured and deployed a report server.

    As Zoe says, the data source should be configured to use stored credentials.

    Only reports that use stored credentials to access a report data source can be distributed through a data-driven subscription. Stored credentials are necessary for unattended report processing.

    In addition, here is a table describing the prerequisites must be met before you create a subscription to a report. Hope this can help you troubleshoot your issue.

    Best regards,

    Lucy Chen


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our Documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    https://docs.microsoft.com/en-us/answers/support/email-notifications


  4. ZoeHui-MSFT 33,626 Reputation points
    2024-05-17T07:20:47.92+00:00

    Hi @Linda,

    Let's confirm that you are using enterprise version SSRS?

    You may check via SSRS configuration manager. Only Enterprise and Developer edition can use DDS.

    In addition, make sure of the data source of your report is using stored credentials.

    User's image

    If you still cannot see DDS, you may open a ticket for Microsoft if you already have paid for license to get directly help.

    Services Hub (microsoft.com)

    0 comments No comments