Azure Open AI Studio: Completions call failed. Please try again.

Jaiswal, Nitin - Admin 5 Reputation points
2024-05-02T12:53:37.5766667+00:00

I have a active subscription for Azure.

I have been using Azure Open AI Studio where I have deployments for GPT 3.5 Turbo and GPT 4 Turbo.

Yesterday, my local Python Environment started to throw the following error:

semantic_kernel.exceptions.function_exceptions.FunctionExecutionException: Error occurred while invoking function geha_assistant_function: ("<class 'semantic_kernel.connectors.ai.open_ai.services.azure_chat_completion.AzureChatCompletion'> service failed to complete the prompt", APIConnectionError('Connection error.'))

Then I went to Azure Open AI Studio to see if things are working. But it was not.

I received the following errors on Notifications under Azure Open AI Studio (screenshot below)

User's image

Then I went into Chat Playground and received same error:

I even regenerated my Keys for my Azure OPEN AI resource but that didnt work.

I even created a New Deployment but still facing the same issue.

Azure AI Search
Azure AI Search
An Azure search service with built-in artificial intelligence capabilities that enrich information to help identify and explore relevant content at scale.
757 questions
Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
2,305 questions
{count} vote

1 answer

Sort by: Most helpful
  1. navba-MSFT 17,900 Reputation points Microsoft Employee
    2024-05-03T01:42:12.6366667+00:00

    @Jaiswal, Nitin - Admin Welcome to Microsoft Q&A Forum, Thank you for posting your query here!

    Please follow the below action plan and check if that helps:

    Plan 1:

    Could you please check if you have enabled the All networks access under the Networking setting within your Azure OpenAI resource as shown below ?

    User's image

    Plan 2:
    Ensure that there are no Private endpoints configured:

    User's image

    Plan 3:

    Could you please confirm if you have a proxy / firewall within your corporate network ? If Yes, Please check if you can bypass it and then try testing again.

    Hope this helps. If you have any follow-up questions, please let me know. I would be happy to help.

    0 comments No comments