(failed) net::ERR_Connection_reset in production site

Brown, Matt 26 Reputation points
2024-05-03T20:57:13.07+00:00

ASP.NET Web Form site worked fine in test. I moved it to production and the site won't come up. I've done a reinstall and double checked all I could. I looked for an answer into this and came away with it being a browser issue when it is not that as this happens to anyone looking at the site. The site uses SSO, but it doesn't even get to that point and it generates the error in the title on the very first hit in the Network tab when I do an inspect. Test site is 2022 while the production server is 2016. Framework for the production site is 4.5.2. I know production has at least 4.6, but I would find it odd if the difference would be the issue.

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,400 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. MotoX80 32,246 Reputation points
    2024-05-04T13:32:05.0166667+00:00

    Do you get different results when you try this while in an RDP session on the server and on some other machine?

    Test basic connectivity with PowerShell.

    Test-NetConnection -ComputerName WhateverNameYouUse -Port 80 
    Test-NetConnection -ComputerName WhateverNameYouUse -Port 443
    Invoke-WebRequest http://WhateverNameYouUse 
    Invoke-WebRequest https://WhateverNameYouUse 
    

    Do basic troubleshooting by checking the Application and System event logs, the IIS logs, and the HTTP error logs in C:\Windows\System32\LogFiles\HTTPERR.

    Check your site bindings and verify that you have the correct host name and IP address. Verify that the certificate you use for HTTPS matches the WhateverNameYouUse value.

    I kept my test and production servers the same OS and same Framework versions.


  2. Michael Taylor 49,246 Reputation points
    2024-05-17T19:07:56.2466667+00:00

    Long list of things to check:

    • What does the event logs say on the web server when you run it?
    • Have you tried browsing the site directly from the server's IIS Manager screen?
    • Have you confirmed the app pool hosting the site is running (as it WAP which it relies on)?
    • Have you confirmed the site is also started and associated with the correct app pool?
    • Is the app pool set to use the v4 runtime of NET Framework?
    • Was NET recently installed or updated? If so was Net Framework (re)registered with IIS? If you have other sites that are also using NET v4 then this likely isn't the issue.
    • Did you confirm that the apppool has permissions to the site directory?
    • Have you confirmed that all the binaries, configs and content needed by the site were deployed correctly?
    0 comments No comments