https at root level not resolving

Dillon Wilson 20 Reputation points
2024-05-06T22:40:28.4+00:00

I'm having an issue with my domain

www.bdenergy.co.nz resolves correct to my static website

https://www.bdenergy.co.nz resolves correctly also

but https://bdenergy.co.nz throws an error

I've added an alias @ A record into azure dns but figure i am missing something???

Azure Front Door
Azure Front Door
An Azure service that provides a cloud content delivery network with threat protection.
594 questions
{count} votes

Accepted answer
  1. GitaraniSharma-MSFT 48,016 Reputation points Microsoft Employee
    2024-05-09T10:17:57.2833333+00:00

    Hello @Dillon Wilson ,

    I understand that you are unable to access your application using the root/apex domain.

    You confirmed that you are using Azure Front Door and have followed the instructions in the official document but still unable to access the domain.

    For Azure Front Door: https://learn.microsoft.com/en-us/azure/frontdoor/front-door-how-to-onboard-apex-domain?pivots=front-door-standard-premium

    I tried accessing your domain on both www and root and I was able to access both of them just fine.

    After you onboard an apex domain, you should follow configuring HTTPS for your custom domain to enable HTTPS for your apex domain.

    Not sure if you missed this step before and did the configuration recently but both www and non-www domains seems to be working fine now.

    If you are still facing issues on your end, could you please clear the local cache and try again.

    And if you still face issues, please share the error message that you are receiving.


    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful