Get-MgEntitlementManagementCatalogResourceRole - Can only retrieve roles for one resource

Mark Brown 25 Reputation points
2024-05-14T15:29:45.9933333+00:00

Hi,

Microsoft.Graph.Identity.Governance

I am not sure if I am doing something wrong, or whether there is an issue, but I am unable to retrieve the role details for my catalog resources.

I have 7 resources assigned to my catalog, but if I run the below command I am only seeing two results, member and owner roles for one resource

Get-MgEntitlementManagementCatalogResourceRole -AccessPackageCatalogId xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx -Filter "(originSystem eq 'AadGroup')"

I am expecting to see the role details for the resources in the catalog

I have tried filtering for the specific ResourceId, but the only way I can retrieve any result is if I use the ResourceId for the only result that was returned previously

I have also tried an Invoke-GraphRequest with "Invoke-GraphRequest -Method GET "https://graph.microsoft.com/v1.0/identityGovernance/entitlementManagement/catalogs/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/resourceRoles?$filter=(originSystem eq 'AadGroup')&$expand=resource"" TNA

Hope you can help as going around in circles

Mark

Microsoft Graph
Microsoft Graph
A Microsoft programmability model that exposes REST APIs and client libraries to access data on Microsoft 365 services.
10,823 questions
PowerShell
PowerShell
A family of Microsoft task automation and configuration management frameworks consisting of a command-line shell and associated scripting language.
2,151 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Mark Brown 25 Reputation points
    2024-05-17T10:40:12.2233333+00:00

    I managed to figure it out. Basically, you cannot retrieve a list of all resource roles like this, you need to specify the individual resource by its resource ID in the filter

    (originSystem eq 'AadGroup' and resource/id eq 'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx' and Displayname eq 'Member')

    0 comments No comments