Error when running Active Directory schema commands for Exchange 2016 installation

Jabulani Motloung 161 Reputation points
2024-05-15T12:30:51.6766667+00:00

Hi Exchange Community,

I am in the process of installing an Exchange 2016 server in our environment, which currently hosts Exchange 2010. However, I encountered an error while attempting to execute Active Directory schema commands. The error message reads: 'The parameter 'iacceptexchangeserverlicenseterms_diagnosticdataoff' is not a recognized option.'

The new server is domain-joined, and the account used belongs to both the Schema Admins and Enterprise Admins security groups. Despite this, I am uncertain about the cause of this error.

Any assistance would be highly appreciated,

Exchange Server
Exchange Server
A family of Microsoft client/server messaging and collaboration software.
1,106 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,387 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Jake Zhang-MSFT 1,535 Reputation points Microsoft Vendor
    2024-05-16T07:52:20.1066667+00:00

    Hi @Jabulani Motloung,

    Welcome to the Microsoft Forum for technical support.

    Based on your description, I noticed that the version you are installing is Exchange Sever2016 CU12. To prepare schema for this version, you should use the command in the format:

    Setup.EXE /m:upgrade /IAcceptExchangeServerLicenseTerms

    For detailed information you can refer to this document: Setup fails for unattended installation of Exchange Server 2019 CU11 or 2016 CU22 or later - Microsoft Support

    Please feel free to contact me if you have any queries.

    Best,

    Jake Zhang


  2. Jabulani Motloung 161 Reputation points
    2024-05-22T12:20:40.4633333+00:00

    Hi @Jake Zhang

    Thanks for the suggestion. I tried but still receiving the same error

    "The parameter 'iacceptexchangeserverlicenseterms_diagnosticdataoff' is not a recognized option"

    Not sure what else to try.

    0 comments No comments