Does deletion of a document in blob will delete the documents data in ai search index

lakshmi 631 Reputation points
2024-05-16T17:31:57.2366667+00:00

Hi team,

We are using 'Azure blob' option to configure private data in blob container and we have created an index and indexer also with scheduling option.

Later we have deleted one document blob , and in indexer we have reset and re run , but still we are getting answers from the deleted document using the same index. is that expected or we need to any extra step to remove the deleted document data from the index.

Azure AI Search
Azure AI Search
An Azure search service with built-in artificial intelligence capabilities that enrich information to help identify and explore relevant content at scale.
811 questions
Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
2,486 questions
{count} votes

1 answer

Sort by: Most helpful
  1. hossein jalilian 4,615 Reputation points
    2024-05-16T18:16:38.9266667+00:00

    Hello lakshmi,

    Thanks for posting your question in the Microsoft Q&A forum.

    You need to take additional steps to remove the deleted document data from the index.

    When you delete a document from the data source, the indexer does not automatically remove the corresponding document from the index. The indexer only updates or adds new documents based on the data source during subsequent runs. and in resetting action, the indexer does not automatically remove deleted documents from the index. It only resets the indexer's internal state and prepares it for a fresh run.

    To remove deleted documents from the index:

    • You need to perform a full index rebuild. This can be done by deleting the existing index and creating a new one, or by using the reset option in the indexer's reset API.
    • You can use the reset option to specify whether you want to keep or remove the existing index data. setting reset=true will remove all existing data from the index before re-running the indexer.

    Please don't forget to close up the thread here by upvoting and accept it as an answer if it is helpful

    1 person found this answer helpful.
    0 comments No comments