Cluster-Aware Updating cannot update this failover cluster. - Error: The failover cluster nodes must be enabled for remote management via WMIv2

Panagiotis Tsamis 0 Reputation points
2024-05-20T17:12:01.17+00:00

I have run the the "WINRM QUICKCONFIG –q" command and it is enabled at all Host Nodes.

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,541 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Alex Bykovskyi 1,831 Reputation points
    2024-05-22T14:20:08.77+00:00

    Hey,

    Check the firewall on the hosts. Firewall should have firewall inbound rule for Windows Remote Management (HTTP-In). https://learn.microsoft.com/en-us/windows-server/failover-clustering/cluster-aware-updating-requirements

    In addition, you should try:

    1. Enable-PSRemoting - force
    2. To confirm the state use: get-service winrm
    3. To enable the remote rule to enable remote shutdown open Windows Firewall with Advanced Security
    4. Set Inbound Rule for Remote Shutdown (RPC-EP-In) to Enabled

    Might also help: https://www.starwindsoftware.com/blog/whip-your-hyperconverged-failover-cluster-into-shape-automatically-and-with-no-downtime-using-microsofts-cluster-aware-updating

    Cheers,

    Alex Bykovskyi

    StarWind Software

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    1 person found this answer helpful.
    0 comments No comments

  2. Ian Xue (Shanghai Wicresoft Co., Ltd.) 32,236 Reputation points Microsoft Vendor
    2024-05-22T04:18:07.86+00:00

    Hi Panagiotis,

    Hope you're doing well.

    According to Microsoft documentation, one of the requirements for using Cluster-Aware Updating (CAU) is that all nodes in the failover cluster must be configured for remote management via Windows Management Instrumentation. This is necessary because CAU uses WMI to perform various operations on the cluster nodes.

    To resolve this error, you need to ensure that WMI is enabled on each node of your failover cluster. By default, enabling remote management might involve setting up a firewall rule to allow automatic restarts triggered by WMI events. However, it's crucial that WMI itself and Remote Registry are allowed through the firewall as well.

    Here are some steps you can follow:

    1. Verify that an administrator account has local administrator rights and permissions on all cluster nodes.
    2. Use the "Validate a Configuration Wizard" provided by CAU tools to check if there are any other issues preventing CAU from running properly.
    3. Ensure that each node's Group Policy Object allows Remote Management and includes any necessary exceptions or configurations related to CAU.
    4. Check if there are any additional software or third-party services installed on your nodes that might interfere with WMI access.

    Here is a relevant doc for your reference:

    Cluster-Aware Updating overview | Microsoft Learn

    Best Regards,

    Ian Xue


    If the Answer is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments

  3. Panagiotis Tsamis 0 Reputation points
    2024-05-22T08:33:51.9533333+00:00

    Hello Ian Xue Thank you for your answer. As you can see from the Cluster Updating Readiness Results, I am getting 2 errors about WMI & PSRemote, but both are installed and enabled in all nodes. I have just notice that in the past month the end customer has install "Microsoft Monitoring Agent" in all nodes. Can this cause the issue? Cluster Updating Readiness

    Best Regards, Panagiotis Tsamis

    0 comments No comments