Trouble emailing an Excel spreadsheet using File > Share > Send Workbook.

Don Meiner 0 Reputation points
2024-05-21T01:06:14.1633333+00:00

I am using a Microsoft 365 Subscription, on a Mac, Version 16.85 (24051214).

I always share a spreadsheet using File > Share > Send Workbook.

Recently I have started receiving this message:

Microsoft Excel cannot access the file '/Users/Username/Library/Containers/com.microsoft.Excel/Data/tmp/Microsoft Office Send Mail/FileName.xlsx'. There are several possible reasons:

• The file name or path does not exist.

• The file is being used by another program.

• The workbook you are trying to save has the same name as a currently open workbook.

I cannot for the life of me figure out what has changed or where to look for a solution to fix this error. Can someone help me?

Microsoft 365
Microsoft 365
Formerly Office 365, is a line of subscription services offered by Microsoft which adds to and includes the Microsoft Office product line.
4,122 questions
Excel
Excel
A family of Microsoft spreadsheet software with tools for analyzing, charting, and communicating data.
1,614 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. hossein jalilian 4,615 Reputation points
    2024-05-21T02:58:16.6366667+00:00

    Thanks for posting your question in the Microsoft Q&A forum.

    It seems that the issue is related to a temporary file path or directory that Excel is trying to access or create during the "Send Workbook" process.

    Sometimes, closing and reopening Excel can resolve temporary file or directory issues.

    Ensure that you have the necessary permissions to create and write files in the temporary directory mentioned in the error message

    Try clearing the temporary files and caches for Microsoft Office applications.


    Please don't forget to close up the thread here by upvoting and accept it as an answer if it is helpful

    1 person found this answer helpful.
    0 comments No comments

  2. Jiajing Hua-MFST 6,820 Reputation points Microsoft Vendor
    2024-05-21T07:39:47.8733333+00:00

    Hi @Don Meiner

    Please try to remove cache files like below:

    • Close Excel, open Finder.
    • Press Command + Shift + G, input “~/Library/Containers”, move ***com.microsoft.Excel ***to desktop.
    • Press Command + Shift + G, input “~/Library/Preferences”, move com.microsoft.office.plist to desktop.
    • Open Excel, and check if it works correctly.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


    0 comments No comments