Unable to request the solutions/virtualEvents/webinars endpoint

Antoine BIDAULT 40 Reputation points
2024-05-21T09:43:11.8+00:00

My objective is very simple : displaying the list of my organization scheduled webinars in Teams on a webpage using MS Graph API. I have a few webinars planned on the calendar which I want to automatically display in a public webpage. I am able to access webinars in teams without any problem.

I've tried to request the solutions/virtualEvents/webinars endpoint without any success (in beta and 1.0)

  • I fetch an access token using the "https://graph.microsoft.com/.default" scope.
  • I use the client_credentials flow with the correct EntraID application client_id, tenantid and client_secret fields

I have granted the following permissions to my entreprise application :

User's image

The api is always returning an empty collection as following :

{
  "@odata.context":"https://graph.microsoft.com/beta/$metadata#solutions/virtualEvents/webinars",
  "value":[]
}

I also tried the api explorer console and the endpoint gives me a 403 forbidden which I am not able to fix even if I grant the permissions.

I am using an MS 365 business standard licence.

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,372 questions
Microsoft Graph
Microsoft Graph
A Microsoft programmability model that exposes REST APIs and client libraries to access data on Microsoft 365 services.
11,057 questions
0 comments No comments
{count} votes

Accepted answer
  1. Hitesh Pachipulusu - MSFT 475 Reputation points Microsoft Vendor
    2024-05-21T10:38:26.4366667+00:00

    Hello @Antoine BIDAULT ,

    Thank you for contacting Microsoft Support.

    According to the documentation, the API returns only webinars whose organizer has been assigned an application access policy.

    You can refer to documentation for configuring application access policy.

    As mentioned in the documentation to run the solutions/virtualEvents/webinars endpoint, we can't use delegated permissions. We get 403 Forbidden error if we use Graph Explorer to run this API. So, we can't use the Graph Explorer.

    Hope this helps.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Antoine BIDAULT 40 Reputation points
    2024-05-21T14:15:19.8966667+00:00

    Thank you ! It worked perfectly. The webinars appear in the feed!

    For those who had the same issue, I've followed the documentation which requires to use some powershell console in order to allow communication between the Entra application and MS Teams.

    I write this in a powershell console :

     Install-Module -Name MicrosoftTeams -Force -AllowClobber
     Connect-MicrosoftTeams
    
    

    Then I've added a policy :

    New-CsApplicationAccessPolicy -Identity TeamAppPolicy -AppIds "06ed3b61-XXXX" -Description "Allow app access"
    

    where 06ed3b61-XXXX is my entreprise application id in Entra

    Then I've granted the permission to the potential webinar organizers user id (repeat the operation for each webinar organizers)

    Grant-CsApplicationAccessPolicy -PolicyName TeamAppPolicy -Identity "<user-id>"
    
    0 comments No comments