Sharepoint Online injects MS Office documents with custom property fields

Thomas Simon 0 Reputation points

Dear Microsoft 365 Community,

We discovered that MS Office documents in our environment get automatically injected with custom property fields (see screenshot below) when they are uploaded to any SharePoint Online site, including Teams and OneDrive.

This is not a desired configuration and is sometimes causing issues with saving and synchronising files. We have no idea how these fields got created or who did it.

With "test tag" 2 and 4, when clicking the symbol on the far-right side, we can select various Term Sets, which seem to come from SharePoint Online Term Store.

Tag 3 shows no choice and 'Test tag' (without any number) is defined as a mandatory field but does not allow any input. Once a user accidently clicks on this field, the document cannot be saved anymore, because Word expects this mandatory field to be filled.

So far, we could not find an option to edit or remove these fields either in Word or SharePoint Online.

How can we remove those undesired fields/properties and stop SharePoint Online from injecting them? I'm aware the Term Store is intended to add metadata to documents, but we could not find any option to adjust/create/delete those test tags.

Best regards

ThomasWord Properties

Microsoft 365
Microsoft 365
Formerly Office 365, is a line of subscription services offered by Microsoft which adds to and includes the Microsoft Office product line.
4,158 questions
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
10,084 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Emily Du-MSFT 43,331 Reputation points Microsoft Vendor

    Per my knowledge, this is a designed SharePoint procedure, it cannot be changed by users. So, custom properties for SharePoint files cannot be removed in the Microsoft word.

    Every file be saved from Microsoft word into document library should in keeping with settings in the SharePoint document library. If you set required property in the SharePoint document library, the required property should be filled in the Microsoft word.

    For the issue that cannot choose term in the managed metadata column, check the term is available for tagging.User's image*************************************************************************

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.