Getting AADSTS501204 Malformed jwt error while logging into Microsoft apps. how to resolve this?

Durga Bhavani Chadala 55 Reputation points
2024-05-22T08:38:27.8133333+00:00

I have changed password for my company account. since then I am facing malformed jwt error when I try to login into Microsoft apps.

I am able to login to microsoft apps through browser with new password but unable to login through installed apps.

It is no even giving me option to relogin and enter new password just throwing error right after entering mail id.

Word
Word
A family of Microsoft word processing software products for creating web, email, and print documents.
722 questions
Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,410 questions
Outlook
Outlook
A family of Microsoft email and calendar products.
3,248 questions
PowerPoint
PowerPoint
A family of Microsoft presentation graphics products that offer tools for creating presentations and adding graphic effects like multimedia objects and special effects with text.
239 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,188 questions
{count} votes

6 answers

Sort by: Most helpful
  1. Oguzhan Oktay 15 Reputation points
    2024-05-24T07:20:47.39+00:00

    Hello All,

    I'm working on Turkey office of a multinational company and we also affected with this issue in many countries especially Europe region.

    We have contacted with MS and create and Incident and discussed with MS engineers start of this week and they accepted the issue and said relaited with April or May updates so they're working to fix and will publish an update or hotfix for this problem.

    We 're waiting them , in paralel we have stopped the deploying updates and IT team reimaging laptops which affected, clean installation fixes issue if you do not get April and May updates.

    3 people found this answer helpful.
    0 comments No comments

  2. Zubair Dawood 15 Reputation points Microsoft Employee
    2024-05-31T15:37:54.5133333+00:00

    This is an internal issue due to a 3rd Party client installation that corrupts the registry key.

    The issue is related to invalid values in the HKEY_USERS.DEFAULT\Control Panel\International\Locale registry

    The workaround steps are:

    1. start checking the current registry value for the locale registry setting
    2. change the value to a supported value like 00000409
    3. Reboot
    4. Check if authentication works now
    5. Note whether reboots or other activities besides the installation of the May 9, 2024 Windows Update are reverting the locale registry value
    3 people found this answer helpful.

  3. Tino Stapelbroek 36 Reputation points
    2024-05-28T15:24:12.93+00:00

    We had the same issue where also windows kb5037771 keeps looping.

    As a solution Microsoft advised to remove the kb, we had several complications where users weren't local admin, We could not make use of local administrator accounts configured in azure. The problem also gave us issues with tanium agent.

    To solve the issue we had to modify the corrupted registry value Locale under HKEY_USERS.DEFAULT\Control Panel\International , the value had corrupted data we needed to change it to 00000413 for dutch for other os languages it will be a different value i suppose. After modifying the REG_SZ value you have to reboot.

    We just applied the fix not sure if it will be stable.

    2 people found this answer helpful.

  4. Jessie Cochran 25 Reputation points
    2024-05-22T23:24:10.6033333+00:00

    We are seeing this issue as well. We use Azure SSO with our DUO MFA for Cisco AnyConnect and have users seeing that error along with the VPN service not starting.

    We have users getting that error when accessing office.com in a regular browser window, but in private mode or Chrome it works without issue. This seems to be something in Edge possibly that could have been pushed in a new update.

    We have Microsoft tickets opened as well as a ticket with DUO

    0 comments No comments

  5. Jessie Cochran 25 Reputation points
    2024-05-23T17:03:03.7666667+00:00

    We have 8 people affected so far all Windows 11 users. Our thoughts is that Windows Update tried to install updates to the OS and possibly Edge and they failed to install and then it corrupted something.

    Everything works fine in Chrome or a Private window. But our VPn launches Edge to authenticate so these people can't work remote.