How to resolve Long Path issue after enabling it in Group Policy and Registry

Ankit Kushwaha 0 Reputation points
2024-05-22T13:58:22.2133333+00:00

Hello,

I have enabled the Long Path issue in gpedit.msc in "Computer Configuration" > "Administrative Templates" > "System" > "Filesystem" and also changed the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem. However, I still cannot create files longer than 256 characters. I am running the VM in VCenter and the OS is Windows 2019 Server Standard 10.0.17763.

I have searched the entire community and tried the above steps, but my issue still persists. Can someone please help me out with this?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,455 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Zunhui Han 720 Reputation points Microsoft Vendor
    2024-05-22T15:12:46.37+00:00

    Hello

    Thank you for posting in Q&A forum.

    Depending on your system environment, if you need to enable paths longer than 260 characters, you can try the following steps:

    1. Press the Windows key, type regedit and press Enter.
    2. Navigate to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\ CurrentVersion\Group Policy Objects\ {48981759-12F2-42A6-A048-028B3973495F} Machine\System\CurrentControlSet\Policies
    3. Select the LongPathsEnabled key and create it as a DWORD (32-bit) value if it does not exist.
    4. Set the value to 1 and close Registry Editor.

    I hope the information above is helpful.

    Best regards

    Zunhui

    ============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.