Escaping single quotes when uploading OAuth Seedfile

Allen, Dave 0 Reputation points
2024-05-23T08:35:07.61+00:00

Hello,

Does anyone know how to escape a single quote when uploading a seed file for OAuth Hardware Tokens.

It's currently driving me mad

And example would be the following

Username: David.A'llen@contoso.com

Whenever I try to upload a seed file with that it always inserts a second single quote so it ends up like this

David.A''llen@contoso.com

Things I have tried.

  1. Wrapping the single quote in single quotes - '''
    1. This results in six single quotes (it effectively doubles them)
  2. Escaping with a back slash
    1. Ineffective
  3. Wrapping the whole string in double quotes
    1. ineffective
  4. many variations of wrapping various bits in quotes
    1. None seem to work

Any Assistance will be of great appreciation

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,147 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Navya 5,570 Reputation points Microsoft Vendor
    2024-05-27T07:40:03.92+00:00

    Hi @Allen, Dave

    Thank you for posting this in Microsoft Q&A.

    I understand that you are trying to upload a seed file for OAuth Hardware Tokens, but you are having trouble escaping single quotes.

    In my environment I attempted to use special characters (like David.A'llen@contoso.com) in UPN and observed the same behavior. My team identified this problem earlier and is currently working to fix it. It will take some time to fix the issue. In the meantime, we suggest a workaround for this issue that Try using the user object ID instead of UPN when using special characters in UPN.

    I tried the workaround on my end, and it worked as expected. I used these headers to upload a seedfile in Entra.User's image

    Hope this helps. Do let us know if you any further queries.

    Thanks,

    Navya.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it.

    0 comments No comments