Getting Access error while trying to enable TCP/IP in Sql server configuration manager

Anvitha Boyapati (V) 0 Reputation points

Hi All,

I wanted to enable TCP/IP protocols in SQL server configuration manager in my local but getting access denied error
Can any one please let me know how to resolve this issue and enable the protocols

User's image

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
13,117 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Erland Sommarskog 104.2K Reputation points MVP

    The obvious question is: Do you have sufficient permissions? SSCM fires a UAC prompt, but if you are not admin on your machine, that may not help. Is this your private machine or are you at work?

    Another possibility is that something is messed up inside WMI. A reboot can be worth trying.

    It could also be some anti-malware program that decided to guard these registry entries with its life and not letting you in.

    If you are in a work environment, and reboot does not help, I think you should talk to your IT folks.

    0 comments No comments

  2. MikeyQiaoMSFT-0444 1,255 Reputation points

    Hi,Anvitha Boyapati (V)

    The issue is largely related to permission issues.

    Is your operating environment a personal computer or within a domain?

    Make sure that SSCM has been run with administrative privileges and ensure that the group policy for domain users is set to modify network configurations.

    Some anti-malware software with high privileges may also block your operations, remember to disable them.

    Lastly, if the above checks are fine, you can try to repair the WMI Provider for SQL Server.

    For instance, 2022 version:

    Go CMD:

    cd C:\Program Files (x86)\Microsoft SQL Server\160\Shared


    mofcomp "sqlmgmprovider.mof"

    For SQL Server 2019 and earlier versions:

    mofcomp "sqlmgmproviderxpsp2up.mof"

    Different versions refer to this.

    Best Regards,

    Mikey Qiao

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments