Solution to the "This app has been blocked by your system administrator" error

Zafer KAYA 0 Reputation points
2024-05-23T13:09:33.8433333+00:00

Hello

Hello, after installing Windows11 22h2, I added my device to the domain. Later, when I try to manage the computer in Task Manager or perform a different operation, I receive a warning that this application has been blocked by your administrator. As a solution to the problem;

All devices running Windows 11 22H2 or later come with the Smart App Control option. Smart App Control (SAC) is a Windows Security feature that helps protect you against malicious apps. To turn this off, go to Computer > HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > CI > Policy in the Registry.

The "VerifiedAndReputablePolicyState" value must be changed to "0". Then restart your computer and the problem will be solved. This problem is usually experienced on Dell Computers. Can you confirm if the problem is solved?
You can try this method

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,941 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,632 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Wesley Li 5,800 Reputation points
    2024-05-27T08:54:48.6766667+00:00

    Hello

    You are sharing a solution to the error ""This app has been blocked by your system administrator", right?

    Thanks for your sharing.

    Since the issue occurred after we joined the machine to the domain, we could open administrator command line and run "gpresult /h C:\gp.html" to check the group policy applied to the machine. If there is any "Software Restriction policy" or Applocker policy has been applied to the mahine.


  2. Zafer KAYA 0 Reputation points
    2024-05-27T09:52:22.65+00:00

    Hello,

    Yes, you can look at the policies implemented by Group Policy as you mentioned. However, in my scenario, a policy that creates this problem is not implemented. I experienced this problem because Smart Application was enabled after Version 22H2. As a solution to this, I changed the registry and the problem was solved.

    Thank you for your return.

    0 comments No comments