vm not connecting RDP

Mohammed Muneef 0 Reputation points
2024-05-24T18:03:44.1033333+00:00

We unable to connect to RDP since its saying RDP power off. when i checking azure port VM is running.

User's image

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,340 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Azar 20,680 Reputation points
    2024-05-24T18:41:57.6566667+00:00

    Hi there Mohammed Muneef

    Thanks for using QandA platform

    1. Reset your RDP connection. This troubleshooting step resets the RDP configuration when Remote Connections are disabled or Windows Firewall rules are blocking RDP, for example. Select your VM in the Azure portal. Scroll down the settings pane to the Help section near bottom of the list. Click the Reset password button. Set the Mode to Reset configuration only and then click the Update button: Screenshot of the Mode setting window of the Reset password tab, in which the Reset configuration only option is selected.

    For more info follow the doc below

    https://learn.microsoft.com/en-us/troubleshoot/azure/virtual-machines/windows/troubleshoot-rdp-connection

    If this helps kindly accept the answer thanks much.


  2. Karlie Weng 15,681 Reputation points Microsoft Vendor
    2024-05-28T07:07:38.52+00:00

    Hello,

    Please also confirm whether the following settings are normal in the remote VM.

    1. Can the IP be pinged?
    2. Confirm that the computer remote desktop function is turned on, right-click the computer -> Properties -> Remote Settings -> Check Allow remote access to this computer
    3. Run the cmd command serves.msc, open the service window, and find two services:

    Remote Desktop Services Remote Desktop Configuration Check whether these two services are started normally. If not, start them manually and double-click to set the service properties to automatic

    1. Run regedit, open the registry, and enter the following two paths to confirm the port:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd\Tds\tcp], find the PortNamber item on the right, which is 3389

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentContro1Set\Control\Tenninal Server\WinStations\RDP-Tcp], find the PortNamber item on the right, which is 3389

    1. Open cmd with administrator and run netstat -ano | findstr 3389, check whether there is any listening information returned
    2. If the listening is abnormal, please export HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp of the machine with the same version in the environment and import it to the abnormal machine to check whether it returns to normal.

    For more info follow the doc below

    General Remote Desktop connection troubleshooting - Windows Server | Microsoft Learn


    If the Answer is helpful, please click "Accept Answer" and upvote it.