How to fix Thumbnails of sites added to collections in the PC version do not load

Marcelo Braunstein 0 Reputation points
2024-05-24T23:02:06.1933333+00:00

A while ago I had a similar experience where images from any website added to the collections would not load on either the PC or mobile versions. On PC the thumbnails simply don't load. An image with a white background is shown with a camera with a "lock" symbol in the center. Which indicates the “failure to load” the image.
Captura de tela 2024-05-24 194446

Among the procedures I have already tried are: Change the DNS - I tried changing the DNS to automatic and also using Google's but it didn't work. Clear browser cache - I tried clearing "cached files and images" but it didn't help. Delete and add the site to favorites - although this is unlikely to resolve the issue, I tried this and it obviously didn't resolve the issue. Disable extensions - I tried disabling all blocking extensions and even others that don't have this purpose, but it didn't help. Check permissions - the sites' permissions are normal, and I've already tried clearing the sites' cookies to see if that would solve the problem or resetting the permissions, but nothing solved the problem. Firewall - I've already checked if there are any blocks in the firewall or protection programs and there is nothing in them. I even tried to make exceptions for Edge to see if it would solve it but it didn't help. (These were procedures I carried out on the PC to try to solve the problem, but I didn't get any results)

I decided to test what would happen if I used a virtual machine (using the virtualBox program). I logged into an account that I had already created a while ago for the same testing purpose. Initially the problem persisted, exactly as it showed on my main account. The same thumbnail loading failure occurred.

Since resetting the browser could help solve the problem, installing Windows from scratch and logging into an account that is almost never used should have the same impact on finding out where the problem is.

I tried changing the DNS within VirtualBox and it seems to have resolved the problem. The images started to load. After that I tried to download EDGE Beta + changed DNS (4221 and 4222): the images loaded. I tried changing the DNS to automatic (the same standard way when we installed Windows) + using EDGE BETA: the images loaded.

Now, with the DNS back to default (automatic), I tried loading the images from the regular Edge browser: the images loaded.

As I continued testing, I noticed that after turning off the virtual machine and turning it on again, this behavior, which showed signs that the problem had been resolved, changed. The loading failures happened again, even under the same circumstances mentioned: DNS, EDGE BETA, etc. In other words, even with the same conditions, things changed from one moment to the next.

I noticed that when a page is full of ads, the ad's thumbnail occasionally fills the site's image when added to collections. But when I try to remove these ads to leave just the website image or the video (as in the case of YouTube), the thumbnail doesn't load.

All of this was what happened inside a Virtual BOX.

However, when I tried changing the DNS on my computer to see if it would have the same effect, there were no changes. The loading failure keeps happening.

I did not perform these tests on the CANARY or DEV versions of Edge. Only in Normal version and BETA version

Currently my Edge is on version 125.0.2535.51 and the same problem keeps happening.

I've been having this problem for a while now and nothing seems to fix it. From what I could understand, not even reinstalling the browser or resetting everything could solve this...

Does anyone have any ideas how this can be resolved?

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,209 questions
{count} votes