in the current api version , tool_choice is not supporting required option. When can we expect this choice?

BurfCoder 0 Reputation points
2024-05-25T05:11:02.0633333+00:00

Hi, I want to use tool_choice = required in function calling. However, it seems like the current version of rest APIs doesn't support this. When can we expect to get this option?

Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
2,482 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Gowtham CP 3,660 Reputation points
    2024-05-25T05:37:37.03+00:00

    Hello BurfCoder ,

    Thanks for reaching out in the Microsoft Q&A!

    Currently, the Azure OpenAI Service does not support the required option for tool_choice. This appears to be a service issue, so I recommend opening a support ticket in the Azure portal for further assistance. The support team can provide you with the most up-to-date information and help resolve the issue as soon as possible. To open a support ticket, please refer to the guide here. Thank you for your patience . Please let me know if you have any other questions.

    If you find this helpful, please accept this answer to close the thread. Thanks!

    0 comments No comments