Exchange 2019 Hybrid Configuration wizard timeout error

Bill Seymour 5 Reputation points

I'm trying to setup hybrid Exchange between my Exchange 2019 server and Microsoft. I'm using the Exchange server for a grand total of two email addresses (different domains), both to the same AD user (me). I'm migrating one domain to make sure everything works, then will add the second domain. My Exchange server is sitting behind NAT with appropriate DNS entries to my Cisco router and it works as expected by itself. I am using Let's Encrypt certificates but am on a residential internet service, so Spamhaus flags me as inappropriate, which means a lot of my emails don't get delivered. My hope is that once the hybrid setup is complete that issue will go away since the MX records will point to MS servers. I've gone through the configuration without issue until I run the hybrid configuration wizard, which fails in the verify stage with this error:

2024.05.25 03:28:53.295 ERROR 10349 [Client=UX, Page=HybridConnectorInstall, Thread=19] The connection to the server '<GUID>' could not be completed., The call to '<GUID>' timed out.

Nothing seem amiss, except the MSAPProxy times out. I assume there is something on my end it doesn't like, so just ignores me. :( Has anyone got ideas on where I go from here?

Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,958 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Amit Singh 4,861 Reputation points

    The error message indicates a timeout when trying to connect to '<GUID>'.

    Here are a few troubleshooting steps you can try:

    • Ensure that there are no network issues preventing your Exchange server.
    • Check if no firewall rules or network configurations blocking the connection.
    • Double-check your DNS settings to ensure that the Exchange server can resolve the hostname '<GUID>' correctly.
    • Verify that your Let's Encrypt certificate is properly configured and trusted by all parties involved.
    0 comments No comments

  2. Noah Ma-MSFT 1,690 Reputation points Microsoft Vendor

    Hi @Bill Seymour,

    Thank you for posting to Microsoft Community.

    Based on your description, I understand you got an error in “Validating Hybrid Agent” page.

    I suggest you could try the following to troubleshoot.

    Also, please check if Exchange Server Extended Protection was turned on, try to turn Extended Protection OFF in IIS (EWS) to see if it works. You could refer to Exchange Server support for Windows Extended Protection | Microsoft Learn for more information.

    Hope it helps and if there are anything else you need help, please feel free to contact me.