iSCSI-Initiator do not reconnect a drive sitting on qnap server

Søren Jensen 20 Reputation points
2024-05-27T12:17:20.58+00:00

Hi All,

I have just finished setting up at new QNAP NAS, where I have used a part of the disk space as an iSCSI Blocked lun. Following the guides in the QNAP guides "How to create and use the iSCSI target service on a QNAP NAS" and "How to set up the QNAP Turbo NAS as an iSCSI storage for Microsoft Hyper-V", I managed to get a F: drive on the server running the hyper-V host. Quickly created a new VM using the Windows Server 2022 eval version, and it all works nicely. I can remotely connect from my other workstations as well.

BUT: After restarting the Hyper-V host, the f: is no more and my new VM cannot start.

Going into the iScsi-initiator show the destination as "Reconnecting.." but it never does. The destination is in the list of favorite destinations, and was since it was connected the first time, so as far as I can tell, it should reconnect without further ado.

I have messed a bit around, restarting the machine a couple of times, removing and adding the destination again, and at some point it connected again. But, as soon as I restart the hyper-v host machine, the drive is not connected again. I am sure the DependOnService is set in the registry, however I'm not sure the name / code for the service is correct. It is set as "SamSS Srv2" which is not the name I recognize.

Obviously I'm missing something, I just can see what it is. Please help !

Regards

Soren

NB! Sorry for the tags. It is not possible to select iScsi-initiator or QNap

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,410 questions
Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,597 questions
Windows Server Storage
Windows Server Storage
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Storage: The hardware and software system used to retain data for subsequent retrieval.
640 questions
0 comments No comments
{count} votes

Accepted answer
  1. Ian Xue (Shanghai Wicresoft Co., Ltd.) 32,156 Reputation points Microsoft Vendor
    2024-05-28T03:36:05.9433333+00:00

    Hi Søren Jensen,

    Hope you're doing well.

    1. Make sure the iSCSI target is still configured correctly on your QNAP NAS. Verify that the target is active and properly configured. And confirm that the target is still listed as a favorite destination in the iSCSI initiator settings on your Hyper-V host.
    2. Check the Windows event logs on your Hyper-V host for any relevant messages related to iSCSI connections or disk management. Look for NTFS error logs or iSCSI disconnection logs.
    3. Try disconnecting the iSCSI target using the iSCSI control panel on your Hyper-V host and then reconnecting it. If the target is stuck in a "Reconnecting" state, this step might help re-establish the connection.
    4. Open Disk Management on your Hyper-V host. Look for the iSCSI disks. If they are not listed, they won't be marked as online. If the disks are listed but not marked as online, try bringing them online manually.
    5. In addition, try changing the policy for iSCSI targets can resolve issues. You can do this using the "diskpart" utility. Open cmd as an administrator and runthe following commands:

    diskpart

    san policy=onlineall

    Note: This command sets the policy to automatically bring all iSCSI targets online.

    1. Ensure that the dedicated network for iSCSI traffic between your QNAP NAS and Hyper-V host is functioning correctly. Verify that the NICs used for iSCSI traffic are separate from the regular LAN NICs.
    2. Reboot your NAS to ensure that any network configuration issues are resolved.

    Remember to document any changes you make during troubleshooting, so you can easily revert them if needed.

    Best Regards,

    Ian Xue


    If the Answer is helpful, please click "Accept Answer" and upvote it.


1 additional answer

Sort by: Most helpful
  1. Alex Bykovskyi 1,831 Reputation points
    2024-05-28T10:11:33.2433333+00:00

    Hey,

    Check the settings on your QNAP box. Might help: https://qnap-singapore.com/faqs/qnap-iscsi-problems-how-to-fix/

    Since your target is on the favorites list, it should reconnect automatically. If your target has CHAP configured, you can try removing it and repeat the test. https://www.edugeek.net/forums/windows-10/185777-iscsi-drive-using-chap-not-auto-connecting-reboot.html

    As another option, you can use StarWind VSAN to create an iSCSI target and connect to your host and perform another reboot to see if the problem related to target or initiator. https://www.starwindsoftware.com/starwind-virtual-san

    Cheers,

    Alex Bykovskyi

    StarWind Software

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.