SMB Multichannel is not supported for the account

Daniel Kaliel 1,261 Reputation points

Coping files using file explorer is significantly slower than the azure file explorer. So I ran this command:

Get-AzStorageFileServiceProperty -StorageAccount $storageAccount | Select-Object -Property ResourceGroupName, StorageAccountName, @{Name = "SmbMultichannelEnabled"; Expression = { if ($null -eq $_.ProtocolSettings.Smb.Multichannel.Enabled) { $defaultSmbMultichannelEnabled } else { $_.ProtocolSettings.Smb.Multichannel.Enabled } } }

Which gave this result:

ResourceGroupName StorageAccountName SmbMultichannelEnabled

xxxxxxxx yyyyyyy False

But when I try to enable SMB multichannel I get the below. What could be wrong?

Update-AzStorageFileServiceProperty -StorageAccount $storageAccount -EnableSmbMultichannel $true

Update-AzStorageFileServiceProperty: SMB Multichannel is not supported for the account.

Azure Storage Accounts
Azure Storage Accounts
Globally unique resources that provide access to data management services and serve as the parent namespace for the services.
2,836 questions
0 comments No comments
{count} votes

Accepted answer
  1. Marcin Policht 16,335 Reputation points MVP

    As per this is available only for Premium File shares

    If the above response helps answer your question, remember to "Accept Answer" so that others in the community facing similar issues can easily find the solution. Your contribution is highly appreciated.



    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Nehruji R 3,801 Reputation points Microsoft Vendor

    Hello Daniel Kaliel,

    Greetings! Welcome to Microsoft Q&A Platform.

    I understand that you’re encountering an issue with enabling SMB multichannel for your Azure storage account.

    SMB Multichannel enables an SMB 3.x client to establish multiple network connections to an SMB file share. Azure Files supports SMB Multichannel on premium file shares (file shares in the FileStorage storage account kind) for Windows clients. On the service side, SMB Multichannel is disabled by default in Azure Files, but there's no additional cost for enabling it.

    If it is Premium file share, then first make sure the binding for the NIC is set to true for SMB client (MS_client) and SMB server (MS_server).

    The command below should show True under Enabled for both: Get-NetAdapterBinding -ComponentID ms_server,ms_msclient

    After that, make sure the network interface is listed in the output of the following commands: Get-SmbServerNetworkInterface Get-SmbClientNetworkInterface

    If everything looks good there, check the firewall. Make sure SMB traffic is not blocked by firewall. If the network profile is set to Public. This means that SMB is blocked at the firewall by default.

    The following article talks about how to troubleshoot SMB Multichannel issue, you could have a look: SMB Multichannel troubleshooting

    Hope this answer helps! Please let us know if you have any further queries. I’m happy to assist you further.

    Please "Accept the answer” and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.

    0 comments No comments