Bug: Remote Desktop for Mac release 10.9.7 appears to break all RDP connections where clipboard sharing is enabled

Mark Schwarz 0 Reputation points
2024-05-28T16:26:41.5433333+00:00

To reproduce:  With clipboard sharing enabled, attempt to connect to one of several different Windows Server hosts from Remote Desktop for Mac. 

 

Expected: Connection to RDP works well.

Actual: The connection hangs indefinitely on "Configuring the remote PC".

 

Note that all of these worked daily for months at a time before the 10.9.7 release was live.  I connect from an M1 Mac (Sonoma 14.2.1) to a 4+ different Windows server instances, varying versions.  On Friday afternoon CT 2024-05-24 they all worked well.  After the release to my Mac, I'm turning off clipboard sharing to each one in order to be able to connect successfully.

 

This blog post works around the issue: https://alexconesa.wordpress.com/2024/02/13/how-to-fix-the-configuring-remote-pc-issue-on-mac-with-microsoft-remote-desktop-app/

 

 

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,353 questions
{count} votes