Issue with Importing New Test Cases into Azure DevOps: "Invalid Workitem Field Values Found" Error

Potashnik, Irena 5 Reputation points
2024-05-28T19:44:04.2666667+00:00

I am facing some challenges importing test cases into ADO using CSV or XLSX files. It worked before, but now it has stopped working. The only way it works now is when I manually create empty test cases and put the IDs in the imported file. In this case, ADO updates the existing test cases with all the fields from the file. For some reason, ADO has an issue creating new test cases.

I tried exporting test cases to a file, removing all IDs, and then importing the same file into a new test suite. However, I get the following error when importing the file: "Error occurred while importing one or more test cases: Invalid workitem field values found."

How can I resolve this issue and successfully import new test cases into ADO without manually creating them first?

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
36,942 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Reimon Ferreira 0 Reputation points
    2024-05-28T19:59:49.0733333+00:00

    The issue you're encountering when importing test cases into Azure DevOps (ADO) might be related to various factors, such as incorrect field values, mandatory fields not being filled, or field constraints.

    Check logs and error messages: Note the detailed error messages provided by ADO during the import process. They often provide specific information about which field or value is causing the problem, and post here.