Cannot connect to Azure Cosmos Mongo DB

Jesse C 0 Reputation points
2024-05-28T23:57:45.76+00:00

Hello, I've deployed an Azure Cosmos DB for MongoDB (vCore) cluster and I cannot connect to anything. I get the error: We are unable to connect to the temporary workspace. Please try again in a few minutes. If the error persists, file a support ticket.

I am currently on a student account where I also have issues of getting the message when sign in sometimes that the account does not exist in tenant 'Microsoft'. But I've also tried to create a mongoDB instance on a different account with just free subscription and I still get the same error of not being able to connect. Attached are the error messages I am getting.

User's image

User's image

Azure Cosmos DB
Azure Cosmos DB
An Azure NoSQL database service for app development.
1,496 questions
{count} votes

1 answer

Sort by: Most helpful
  1. akinbade abiola 4,670 Reputation points
    2024-05-29T00:16:56.2866667+00:00

    Hello Jesse C,

    Thanks for your question.

    Were you able to perform this operation with this user before?

    If you've been able to login previously, can you try to login in using a private browsing session or maybe open a different browser like edge and test?

    For further troubleshooting see:

    https://learn.microsoft.com/en-us/troubleshoot/azure/entra/entra-id/app-integration/error-code-AADSTS50020-user-account-identity-provider-does-not-exist

    Please let me know if you have further questions

    You can mark it 'Accept Answer' if this helped.