How to use <username>/Desktop instead of <username>/OneDrive/Desktop

PhaedraFlux 0 Reputation points
2024-05-29T03:13:29.5966667+00:00

I never signed in to OneDrive (on any computer), I never set it up on any PC, and I uninstalled it. But STILL it creates a OneDrive Folder every single time I restart the computer. And it seems to be where it's actually loading the Desktop stuff from. I do not have office or any other MS shit installed except what comes by default and can't be uninstalled. How the hell can I get it to go back to the normal desktop location? I've tried https://docs.microsoft.com/en-us/answers/questions/439113/removing-onedrive-traces-remaining-after-uninstall.html) (I had to create the office paths referenced), but that did nothing. Please help me remove the spyware that is OneDrive from my brand new windows install.

OneDrive
OneDrive
A Microsoft file hosting and synchronization service.
910 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Jiajing Hua-MFST 6,745 Reputation points Microsoft Vendor
    2024-05-29T07:43:46.48+00:00

    Hi @PhaedraFlux

    Please go to Windows Settings > Apps > Installed Apps, please make sure there is no Microsoft OneDrive installed.

    If so, please go to Registry Editor, locate to Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders, then find the "Desktop" value, make sure its value data is "C:<username>\Desktop" or "%USERPROFILE%\Desktop".

    User's image

    Before you modify it, please remember to back up the registry for restoration in case problems occur.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


    0 comments No comments