How to disable ActiveX messages in MS Edge in IE compatibility mode in Win 10?

john 5 Reputation points
2024-05-29T11:27:28.19+00:00

I have a particular website that only uses IE. So in Win10 it seems like IE is no longer runable as a separate thing, I have to use Edge in IE compatibility mode. Fine. The website works under this configuration, except that it keeps popping up with annoying messages:

"A script is accessing some software (an ActiveX control) on this page which has been marked safe for scripting. Do you want to allow this? [YES/NO]"

This is highly annoying and I want to disable it, for this website at least.

However, if I go into tools > internet options > security all of the buttons seem to be greyed out. (I'm pretty sure this is where this sort of thing used to be done). If I go into trusted sites the "sites" button is not greyed out, but I am then unable to add/remove trusted websites. Strangely an old website is listed, but I can't remove it nor can I add a new one.

I suspect this is old IE functionality that has been disabled?

So how do I get rid of these messages?

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,204 questions
Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,941 questions
Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,930 questions
{count} votes

2 answers

Sort by: Most helpful
  1. john 5 Reputation points
    2024-05-29T12:50:42.1966667+00:00

    As I mentioned in my post, I tried that (via the menu) and the buttons are all greyed out. I tried running the .cpl as you suggested, even specifically opening it as administrator, and the buttons are still greyed out.

    User's image

    1 person found this answer helpful.

  2. Zunhui Han 640 Reputation points Microsoft Vendor
    2024-05-29T12:41:46.57+00:00

    Hello,

    Thank you for posting in Q&A forum.

    regarding the issue of using ActivityX controls in Edge, you can search for inetcpl.cpl in the Windows search bar to open the settings for ActivityX controls.

    Find the custom level in the security column.

    User's image

    The following are the options related to ActiveX controls and plug-ins.

    User's image

    I hope the information above is helpful.

    Best regards

    Zunhui

    ============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments