Incorrect Time and Incorrect Time Zone

Stuart F72 0 Reputation points
2024-05-30T08:16:16.14+00:00

I am running windows 10 Home on an HP PC, which was originally set up in the UK, but is now in NZ and all had been working fine til we had a powercut last night. No data lost, but since I rebooted the time has resolutely stayed 2 hours adrift from NZ time, as it insists that I be on Chennai time. When I go to Settings / Time & Language / Time and toggle it on and off, it always identifies me as being in Chennai and resets the clock to that time zone. Whilst I can toggle off auto time and time zone and set it manually, that's not a long term fix as I need it to be on NZ time, adjust for summer time etc etc. I have tried rebooting and it just defaults to Chennai again and it's driving me nuts!

Any advice?

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,967 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Ian Xue (Shanghai Wicresoft Co., Ltd.) 32,326 Reputation points Microsoft Vendor
    2024-06-03T06:41:42.55+00:00

    Hi Stuart,

    Thanks for your post. Generally speaking, In Date & time, you can choose to let Windows 10 set your time and time zone automatically, or you can set them manually.

    To set your time and time zone in Windows 10, go to Start  > Settings  > Time & language > Date & time.

    Also, please make sure the region is also set in Control Panel >Region >Administrative > current location.

    Best Regards,

    Ian Xue


    If the Answer is helpful, please click "Accept Answer" and upvote it.


  2. Stuart F72 0 Reputation points
    2024-06-03T10:29:08.72+00:00

    Thanks, but I've done all of that AND, AS ABOVE, whether I do it manually or leave it to the system, it is incorrect

    0 comments No comments