new to Azure, free credits consumed without deploying

Mustafa G 0 Reputation points
2024-06-01T19:57:23.3933333+00:00

I am new to Azure, and I wanted to explore the tools. But somehow my free 200$ credits got consumed, while I didnt deploy anything at all. Can you please help me to understand why this happend? also is there a possibility to revert it? I cant somehow not create support ticket, as it redirects me to another link (http://aka.ms/AzureSubHelp) and once there, during ticket creation it forwards me again to the Azure portal. running in circles here.

Azure AI services
Azure AI services
A group of Azure services, SDKs, and APIs designed to make apps more intelligent, engaging, and discoverable.
2,536 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Sander van de Velde | MVP 30,556 Reputation points MVP
    2024-06-01T20:17:14.2833333+00:00

    Hello @Mustafa G,

    welcome to this moderated Azure community forum.

    Sorry to hear you have some challenges with the free subscription.

    It's hard to understand why you run into this and I have limited experience with the free account.

    There are a couple of thing you could try.

    First, open the Azure portal in a in-private session so you know for sure the right account is used.

    If the account is used for multiple subscriptions (like other companies), try to change the Directory (seen in the upper right corner of the portal):

    User's image

    Next, but I'm nor sure if this is available in a Free account, try to open the 'Subscription' page within the portal. Hopefully, you get more billing details there.

    Last but not least, you could try the chat at https://azure.microsoft.com/en-us/free:

    User's image

    It seems Billing support is offered.


    If the response helped, do "Accept Answer". If it doesn't work, please let us know the progress. All community members with similar issues will benefit by doing so. Your contribution is highly appreciated.

    0 comments No comments