how to fix , The application was unable to start correctly (0x000007b) click ok to close the application

zdruidxx 0 Reputation points
2024-06-02T15:14:31.0033333+00:00

I've been attempting to open this file, but each time I try, I receive an error saying that the code execution cannot continue because VCruntime140.dll was not found. It suggested reinstalling the program to potentially resolve the issue. I tried a method I found online that involved copying some files into the system32 and sysWOW64 folders. After following those steps, the previous error message disappeared. However, when I tried to open the file again, a new error popped up, stating, The application was unable to start correctly (0x000007b),prompting me to close the application. i use window 11 / 64 bit. please help

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,438 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. MotoX80 32,526 Reputation points
    2024-06-02T17:01:20.4233333+00:00

    It suggested reinstalling the program to potentially resolve the issue

    Why did you try to manually copy files and not reinstall the program?

    Some programs are designed to be portable where you can just copy the .exe file one pc to another and just run it. Other programs have dependent dll's and those dll's may themselves depend on other dll's. And registry entries, and folder permissions, and config files, etc.

    The correct way to resolve that problem is to run the .MSI install file or setup.exe that properly installs the program.

    It appears that you put a 32 bit dll into the 64 bit folder or vise versa.

    https://www.thewindowsclub.com/0x000007b-the-application-was-unable-to-start-up-correctly

    I would recommend undoing whatever file copies that you did and contact the developer and get the correct install files.

    If the application is no longer supported and an install setup.exe does not exist, then you should first try to find a different, supported program that performs the same functionality.

    The last resort would be to run Process Monitor and see what files the .exe is looking for and try to manually replace the files.

    https://learn.microsoft.com/en-us/sysinternals/downloads/procmon

    The last dll that it loads before the 0x000007b error is probably the one with the wrong bitness.

    0 comments No comments

  2. Ian Xue (Shanghai Wicresoft Co., Ltd.) 32,236 Reputation points Microsoft Vendor
    2024-06-04T04:24:46.1066667+00:00

    Hi zdruidxx,

    Thanks for your post. Based on my research, VCRUNTIME140.dll is one of the runtime libraries for Microsoft Visual Studio (Visual C++). Do you use theAdobeIPCBroker? If so, the AdobeIPCBroker.exe is the Creative Cloud app, this error means the Visual C++ library is corrupted.

    Step 1- Remove all Visual C++ library

    1-RIght-click on Start then click on Run

    2-Type: control panel and click on Ok

    3-Click on Uninstall a program

    4-Search and uninstall all "Microsoft Visual C++ redistributable"

    5-Reboot your PC

    Step 2 - Reinstall the Visual C++ library

    1-Download and the latest version at this link. https://aka.ms/vs/16/release/vc_redist.x64.exe

    2-Execute and follow the instructions

    Best Regards,

    Ian Xue


    If the Answer is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments