Visual Studio 17.10 no longer shows Publish command

Steve Nicholson 20 Reputation points
2024-06-04T19:45:17.47+00:00

I updated to VS 17.10 on my desktop computer. It no longer shows the publish command for my project. My laptop is still running VS 17.9 and does show the publish command.

Desktop:

desktop

Laptop:

laptop

I looked under Individual components in the Visual Studio installer and all of the components related to publishing are installed on both. Did the Publish command get moved in 17.10?

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,793 questions
{count} votes

Accepted answer
  1. Anna Xiu-MSFT 27,231 Reputation points Microsoft Vendor
    2024-06-05T03:33:29.9466667+00:00

    Hi @Steve Nicholson

    Welcome to Microsoft Q&A! 

    It is noted that not all project types support publishing. You can create a new project and check that the Publish command displays properly. 

    If the project on the desktop is the same type as the project on the laptop, please close all running VS instances and open the Visual Studio Installer > More > Repair your VS2022. Then, re-launch your VS and check it again. 

    If the project was copied from laptop to desktop device, please check if the project files are different. 

    If you have any third-party extensions installed, please temporarily disable them.

    Sincerely,

    Anna


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".  Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Steve Nicholson 20 Reputation points
    2024-06-05T18:08:24.9833333+00:00

    Using Visual Studio Installer > More > Repair your VS2022 brought back the Publish command. Thanks.

    0 comments No comments