Azure SignalR Service (Serverless) - Stopped working

Mohammed, Kazim 20 Reputation points
2024-06-05T06:07:54.7933333+00:00

Hello in Support

The SignalR service was working until today, now it's not working, means it is not reachable

.\psping.exe cirruspl-at53286-signalrcuration-t1-chn-001.service.signalr.net:443

 

PsPing v2.10 - PsPing - ping, latency, bandwidth measurement utility Copyright (C) 2012-2016 Mark Russinovich Sysinternals - www.sysinternals.com

 

Invalid destination address: Host not found.


Not sure what caused the issue all of the sudden. I tried to recreate the service couple of times, restarted several times but no success.

Any idea would be helpful?

Azure SignalR Service
Azure SignalR Service
An Azure service that is used for adding real-time communications to web applications.
127 questions
{count} votes

Accepted answer
  1. ajkuma 23,641 Reputation points Microsoft Employee
    2024-06-05T08:05:54.0666667+00:00

    @Mohammed, Kazim ,

    I’m sorry to hear that you’re having trouble with Azure SignalR Service.

    I understand you have tried multiple steps isolate the issue and the issue occurred without any specific changes, kindly try the following steps to further narrow down the issue:  

    Azure SignalR service provides live trace tool to expose service traces on connectivity and messaging categories.  Please see How to capture service traces - The traces include but aren’t limited to connection connected/disconnected events and message received/left events.

    Also, if you haven’t done it already, kindly capture and review the network trace.

     

    Additionally, please check Service Health and Resource Health status for more info.

    Azure Service Health provides you with a customizable dashboard which tracks the health of your Azure services in the regions where you use them Azure Resource Health helps you diagnose and get support for service problems that affect your Azure resources. It reports on the current and past health of your resources.

    Troubleshooting guide for Azure SignalR Service common issues

    Kindly let us know how it goes, I'll follow up with you further.

     

     ---
    If the answer helped (pointed you in the right direction) > please click Accept Answer - it will benefit users in finding the right answer quickly.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Mohammed, Kazim 20 Reputation points
    2024-06-11T04:11:13.0466667+00:00

    Thank you for your hint pointing to the DNS server.

    Indeed, the issue was related to the internal DNS server.

    A (false) event that sent both a 'create record' and then 'delete record' signal to our function app that manages this records. Internal networking team fixed the issue by adding the record.