IPAM Server disconnected during In-Place OS Upgrade from 2016 to 2019/2022

Ramy Anwer 0 Reputation points
2024-06-05T07:12:02.7+00:00

Dear Microsoft Team,

Good day,

I faced an issue during the upgrade of the OS server for IPAM from 2016 to 2019/2022, I tried to upgrade to both OS systems, and every time I faced the same error, "Log in to database failedUpgrade Error

I tried to check both services [ Windows Internal Database - Windows Process Activation Service] both services are running well.

Event Viewer showing a critical error with event ID 60002 including that information

Connecting to IPAM database failed with,

Number: 18456

ErrorCode: -2146232060

Level: 14

State: 1

Message: Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.

For database,

Database Type: WindowsInternalDatabase

Database Authentication Type: WindowsAuthentication

Database Name: IPAM

**Database Path: E:\IPAM\DataBase**

Database Server: 

Database Server Port: 0

Username: 

when I run Get-IpamDatabase

DatabaseType : WID

WidSchemaPath : E:\IPAM\DataBase

DatabaseServer :

DatabaseName : IPAM

DatabasePort :

DatabaseAuthType : Windows

DatabaseUser :

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,548 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Wesley Li 5,955 Reputation points
    2024-06-21T15:32:14.1066667+00:00

    Hello,

    Please check the following Settings.

    Folder permissions:

    Ensure that the E:\IPAM\DataBase folder and its contents have appropriate access to the NT AUTHORITY\NETWORK SERVICE account. This usually means that the NETWORK SERVICE account needs to have read and write access to the folder.

    Service identity:

    Ensure that the Windows SERVICE running IPAM-related services, such as the IPAM service, is running as a NETWORK SERVICE. If not, change it to use this identity.

    Database file integrity:

    Check that the DataBase files in the E:\IPAM\DataBase folder (typically.mdf and.ldf files) are intact and uncorrupted.

    0 comments No comments