Intellisense not working in XAML VS 22 17.10.1

Lyubomir Radev 0 Reputation points
2024-06-05T11:42:51.9433333+00:00

I am using VS 22 17.10.1 and I am having trouble with Intellisense. I don’t get autocomplete for the Avalonia AXAML files. If I go to Tools=>Options=>Text Editor=> XAML in VS I see that the Statement Completion area is completely disabled and I can’t turn on or off the settings there(see image). I’ve tried the following;

  1. Deleting the vs folder in the solution repository
  2. Deleting the entire repository and cloning it again
  3. Repairing VS from the Visual Studio Installer
  4. Downgrading my VS version to 17.4.0
  5. Reinstalling VS Build Tools
  6. Removing Copilot
  7. Uninstalling and Installing IntelliCode
  8. https://stackoverflow.com/questions/61924136/intellisense-doesnt-work-in-large-xaml-file

Do you have any suggestions how to fix this because it is blocking my work as a whole.

Also I am not using Resharper.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,792 questions
XAML
XAML
A language based on Extensible Markup Language (XML) that enables developers to specify a hierarchy of objects with a set of properties and logic.
779 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Anna Xiu-MSFT 27,231 Reputation points Microsoft Vendor
    2024-06-06T03:26:24.42+00:00

    Hi @Lyubomir Radev, 

    Welcome to Microsoft Q&A! 

    If it is an Avalonia application, Avalonia XAML files have the extension .axaml not .xaml.

    You need to install Avalonia for Visual Studio 2022 extension to get IntelliSense support for Avalonia XAML. 

    If you have installed the extension, please uninstall it and reinstall the latest version 11.5.

    If the IntelliSense still doesn’t work in Avalonia application, I suppose it may be a known issue. You can see the similar issue.

    You need to contact the Avalonia Team in GitHub to check it. Thanks for your understanding! 

    Sincerely,

    Anna


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".  Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.