Authentication fails for new document intelligence resources

James Coates 0 Reputation points
2024-06-05T14:43:38.7633333+00:00

Hey,

I'm experiencing an issue with Azure Document Intelligence where if I create a new document intelligence resource in the East US region, I can not authenticate to use it. I will get the following error:

(401) Access denied due to invalid subscription key or wrong API endpoint. Make sure to provide a valid key for an active subscription and use a correct regional API endpoint for your resource.

It is worth noting that I am able to authenticate with and use a Document Intelligence resource that I have created previously.

I have tested across multiple subscriptions and even different Azure accounts and I am getting the same issue everywhere, so it isn't subscription or account specific. I have been able to authenticate with resources created in other regions such as UK South but not East US.

It is also worth noting that I am unable to use document intelligence studio with these resources as well, where I get the same issue. This doesn't require me to enter the endpoint and key so I am pretty sure it is not a mistake on my side from entering the wrong authentication information (although could always be a mistake elsewhere).

This seems like a more general Azure issue to me, but Microsoft throw so many self serve things at you, I am unable to find how I even notify them of this issue.

Any help would be greatly appreciated!

Azure AI Document Intelligence
Azure AI Document Intelligence
An Azure service that turns documents into usable data. Previously known as Azure Form Recognizer.
1,470 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. VasaviLankipalle-MSFT 15,241 Reputation points
    2024-06-05T18:26:33.93+00:00

    Hello @James Coates , Thanks for using Microsoft Q&A Platform.

    Sorry for the inconveniences that has caused. Can you confirm if you haven't made any changes to the subscription; like created one in less than 24 hours something like that?

    Generally, the issue might be related to the API endpoint or subscription key. Looks like you have done troubleshooting steps in double-checking that you are using the correct regional API endpoint for your resource in the document intelligence studio.

    User's image

    If you are sure that you are using the correct API endpoint, you can try re-generating your key in the Azure portal (under your resource->keys & endpoint) and using the new key to authenticate. It is possible that the key might expired.

    User's image

    If neither of these solutions work, I would suggest raising a support ticket in the Azure Portal for further assistance. I hope this helps.

    Regards,

    Vasavi

    0 comments No comments