How to disable SSPR for specific users?

Mychael Jones 0 Reputation points
2024-06-05T20:15:08.0566667+00:00

We have 3 computers that share a Microsoft 365 account. While replacing one of the 3 computers, Microsoft asks for "More information required ... Your organization needs more information to keep your account secure" and then requests that I verify the identity. How do I disable this verification of identity for these specific computers?

Our organization has MFA disabled by default, but we have SSPR enabled for all accounts. I believe the SSPR is causing the issue, but I really don't know. Is there a way to disable SSPR for specific accounts? Can I setup a group and set this as a policy?

I have another 140 something user accounts, that work just fine with SSPR and MFA (as needed), but these 3 computers are the only ones that share Microsoft 365 accounts.

Any help would be appreciated.

Azure Policy
Azure Policy
An Azure service that is used to implement corporate governance and standards at scale for Azure resources.
815 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,147 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Vasil Michev 98,206 Reputation points MVP
    2024-06-06T06:11:23.04+00:00

    SSPR is configured per user, the computer/device does not matter here. In addition, there is no functionality to directly exclude a user from SSPR requirements. Instead, you need to do it the other way around - define a group on members of which the SSPR requirements will be enforced, and do not add the user(s) you want to exclude as members of the group.

    The process isn't very flexible, as only a single group can be specified, and only in "include" mode, but it should be sufficient to address your scenario. Details are here if you need them: https://learn.microsoft.com/en-us/entra/identity/authentication/tutorial-enable-sspr#enable-self-service-password-reset

    0 comments No comments