visual studio 2022 visual basic navigation bar dropdown not working after updating to 17.10.1

KimW 0 Reputation points
2024-06-07T15:23:20.54+00:00

VS issue1.png

When I look at the code for a form, the middle drop down in the navigation bar is missing all the controls. The code for the controls in moved to the far right drop down (like it would if it is missing a handles clause). If I click on one of them in the far right it opens the code for the control and it looks OK, but I still get no controls in the middle drop down. And no event list in the third dropdown since I cannot select a control from the middle list. The only thing that shows in the middle dropdown is the form itself.

In searching I see this issue (or something very similar) from updates in the past that was supposedly fixed.

Using

Microsoft Visual Studio Professional 2022 (64-bit) - Current

Version 17.10.1

I have rebooted my computer. Opened another project to see if it worked there and it did not.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,757 questions
VB
VB
An object-oriented programming language developed by Microsoft that is implemented on the .NET Framework. Previously known as Visual Basic .NET.
2,624 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Michael Taylor 49,701 Reputation points
    2024-06-07T16:11:03.1333333+00:00

    You should use the Report a Problem feature in VS to report the issue with MS. They will be able to see if this is a regression issue or not. Also it is important to note whether you're using the new designer or the old one. Try switching the option in the Tools \ Options section. In either case you can record the issue and have it sent directly to MS so they can research further.

    0 comments No comments

  2. Anna Xiu-MSFT 27,251 Reputation points Microsoft Vendor
    2024-06-10T06:14:35.7233333+00:00

    Hi @KimW,

    Welcome to Microsoft Q&A! 

    I tested it with the latest VS2022 version 17.10.1 and the controls do appear in the middle navigation dropdown.

    User's image

    You can try to reset the window layout by clicking on Window > Reset Window Layout

    Then, close all running Visual Studio instances and open the Visual Studio Installer > More > Repair your VS. 

    If the new created project is working fine, you can consider copying your code into the new project. 

    Sincerely,

    Anna


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".  Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  3. PayPak Professional 0 Reputation points
    2024-06-13T08:30:08.84+00:00

    KimW,

    I upgraded to Visual Studio 17.10.2 yesterday and immediately got this annoying problem, which previous recent versions only seemed to occur randomly on opening some forms and lasted only for a few seconds. But now it is permanent. I search the internet for a solution and that brought me here yesterday but I found no solutions. So after some tinkering around I found a way to get around it until Microsoft fixes it.

    On opening the code editor, if you edit any line of code the controls will reappear in the navigation bar middle dropdown list, but I did not want to tamper with the actual code itself.

    The easiest way of fixing this problem is to open a form at or near the top of the solution explorer list, look for the first blank line and add a single apostrophe. As soon as this is done the dropdown list will show the controls. Making the change for one form will enable the dropdown list for all forms in the project, so you only have to do it once. However, when next you open the project the problem will return but it can be easily fixed again by removing the apostrophe (adding a second one would also work). Opening the project a third time you have to add the apostrophe again. Please note that adding spaces does not work.

    Hope this helps.

    0 comments No comments