Mongo DB and Mongo DB Atlas connectors in ADF compatibility

Martin 0 Reputation points
2024-06-11T08:45:01.4633333+00:00

Hello,

Is it true that both connectors - the Mongo DB and the Mongo DB Atlas connector are incompatible with higher than 4.2 versions of Mongo DB? Or is it only the first one and the second is may be compatible with higher versions?

If they both are incompatible, do you plan to implement compatibility with higher versions any soon?

If they both are incompatible, then it is impossible to use the Copy Activity of the Azure Data Factory with higher versions than Mongo 4.2, right?

Thank you for your answer in advance!

Best,

Martin

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,894 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Smaran Thoomu 11,370 Reputation points Microsoft Vendor
    2024-06-11T11:19:07.6266667+00:00

    Hi @Martin

    Thank you for your query regarding the compatibility of the Mongo DB and Mongo DB Atlas connectors with higher than 4.2 versions of Mongo DB.

    As per the Azure documentation, both connectors are currently incompatible with higher versions than Mongo 4.2. Unfortunately, there is no information available on when compatibility with higher versions will be implemented.

    If both connectors are incompatible, then it is not possible to use the Copy Activity of the Azure Data Factory with higher versions than Mongo 4.2.

    Hope this helps. Do let us know if you any further queries.


    If this answers your query, do click Accept Answer and Yes for was this answer helpful. And, if you have any further query do let us know.

    0 comments No comments