Cannot connect to my VM

TAZDAIT, Yacine 40 Reputation points
2024-06-12T16:20:02.2233333+00:00

Hello,

I'm trying to connect to my Ubuntu 22.04 VM as usual. However, when I attempt to connect through the portal using SSH with Azure CLI, it prompts me to enter a password, which it never did before. I have tried every password, including previous ones, but none work and I receive the following error after attempting several times: Permission denied (publickey,password).

I also regenerated the SSH key, configured the security group to make my VM accessible through port 22, and reset the user's password, but none of these solutions worked and it prompts the same error after several attempts.

Please, note that the username registered when I created the VM is different from my personal username. When I try to connect using the username I set up, it works, but when I use my personal one, it doesn't work, even though it was working until now.

Can someone help me solve this problem, please?

Any help would be much appreciated.

Regards,

Yacine

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,547 questions
0 comments No comments
{count} votes

Accepted answer
  1. Marcin Policht 18,005 Reputation points MVP
    2024-06-12T16:56:58.1666667+00:00

    You should be using the username set when provisioning the VM.

    You could use your Entra ID account assuming that you enable Entra ID integration for the VM. For that, follow https://learn.microsoft.com/en-us/entra/identity/devices/howto-vm-sign-in-azure-ad-linux


    If the above response helps answer your question, remember to "Accept Answer" so that others in the community facing similar issues can easily find the solution. Your contribution is highly appreciated.

    hth

    Marcin

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful