Disabling autocompletion from anything else than Tab in VS 2022

Coco_l_asticot 20 Reputation points
2024-06-18T09:34:12.84+00:00

Although I set "Default IntelliSense completion mode" to Tab-only in Text Editor/Advanced, Visual Studio keeps replacing text as I type with its first suggestion when I press e.g. space or dot. I do not want the editor to ever autocomplete unless I press Tab, apart maybe from closing parentheses, braces etc.

I thought this could possibly be due to a language-specific setting, so I also went into the C++ text editor settings and deleted all characters under "Text Editor/C/C++/Advanced/IntelliSense/Member List Commit Characters. But that didn't seem to solve the issue either. Any help is welcome...

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,857 questions
C++
C++
A high-level, general-purpose programming language, created as an extension of the C programming language, that has object-oriented, generic, and functional features in addition to facilities for low-level memory manipulation.
3,625 questions
0 comments No comments
{count} votes

Accepted answer
  1. Anna Xiu-MSFT 27,731 Reputation points Microsoft Vendor
    2024-06-19T03:49:38.0433333+00:00

    Hi @Coco_l_asticot

    Welcome to Microsoft Q&A! 

    Please re-run your VS as administrator. 

    You can use the option to change the IntelliSense completion mode: Edit > IntelliSense > Switch between automatic and tab-only IntelliSense completion or shortcut: Ctrl+Alt+Space. In suggestion mode, only the text you type is inserted into the code. 

    Update:

    To disable autocomplete behavior when pressing space in a C++ project, you can go to Tools > Options > Text Editor > C/C++ > Advanced > IntelliSense > set “Use Aggressive Member List for Auto Member List” to “True”.

    Sincerely,

    Anna


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".  Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


1 additional answer

Sort by: Most helpful
  1. Coco_l_asticot 20 Reputation points
    2024-06-25T08:22:53.6566667+00:00

    This suggestion I received in the corresponding Developer Community thread solved the issue for me: In “Tools>Options>Text Editor>C/C++>Advanced”, under “IntelliSense”, set “Use Aggressive Member List for Auto Member List” to “True”

    0 comments No comments