Error while configuring the 'own data' in azure open ai from azure blob storage

lakshmi 671 Reputation points
2024-06-19T10:33:24.7366667+00:00

Hi Team,

We are getting the below error while configuring the documents stored in Azure storage blob container using azure open ai add your own data feature.

We have 'Enabled from all networks' in storage network tab and provided 'Storage Blob Data Contributor' role for open ai, ai search and the user who does configuration.

Also user has contributor role in all these services still we are getting the below error message.

Error message :

We couldn't connect your data

Error with data source: For more information on troubleshooting connection issues to Azure Storage accounts, please see https://go.microsoft.com/fwlink/?linkid=2049388 Please adjust your data source definition in order to proceed. Status: 0 Service request succeeded. Response content and headers are not included to avoid logging sensitive data.

Azure Storage Accounts
Azure Storage Accounts
Globally unique resources that provide access to data management services and serve as the parent namespace for the services.
2,924 questions
Azure AI Search
Azure AI Search
An Azure search service with built-in artificial intelligence capabilities that enrich information to help identify and explore relevant content at scale.
862 questions
Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,623 questions
Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
2,614 questions
{count} votes

Accepted answer
  1. Nehruji R 4,606 Reputation points Microsoft Vendor
    2024-07-18T11:50:11.4266667+00:00

    Hi lakshmi, I'm glad that you were able to resolve your issue and thank you for posting your solution so that others experiencing the same thing can easily reference this!

    Since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others ", I'll repost your solution in case you'd like to "Accept " the answer. Accepted answers show up at the top, resulting in improved discoverability for others.

    Issue: Error while configuring the 'own data' in azure open ai from azure blob storage.

    Error Message:

    We couldn't connect your data

    Error with data source: For more information on troubleshooting connection issues to Azure Storage accounts, please see https://go.microsoft.com/fwlink/?linkid=2049388 Please adjust your data source definition in order to proceed. Status: 0 Service request succeeded. Response content and headers are not included to avoid logging sensitive data.

    Solution: Customer have created a new shared private access from search to blob and it works now.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Anand Prakash Yadav 7,780 Reputation points Microsoft Vendor
    2024-06-20T08:18:14.6333333+00:00

    Hello lakshmi,

    Thank you for posting your query here!

    I understand that you are facing a connection issue between Azure OpenAI and Azure Blob Storage despite correct network and role configurations.

    Storage accounts in virtual networks, firewalls, and private endpoints are supported by Azure OpenAI on your data.

    1.Ensure you have the system assigned managed identity principal enabled for your Azure OpenAI and Azure AI Search resources.

    • Using the Azure portal, navigate to your resource, and select Identity from the navigation menu on the left side of the screen.
    • Set Status to On.
    • Perform these steps for both of your Azure OpenAI and Azure AI Search resources.
      User's image

    2.Navigate back to your storage account. Select Access Control (IAM) for your resource. Select Add, then Add role assignment. In the window that appears, add the Storage Data Contributor role to the storage resource for your Azure OpenAI and search resource's managed identity.

    • Assign access to Managed Identity.

    If you have multiple search resources, Perform this step for each search resource.
    User's image

    3.As you mentioned, your storage account is not network restricted, go to networking tab and select Enabled from selected virtual networks and IP addresses.

    User's image

    Also, for production don't forget:
    User's image

    Note: It might take some time (not more than 30 min) for the changes to reflect.

    Also, please verify that the data source definition is correct and complete. Make sure that the container name and the folder path match the ones in the azure portal.

    Further details: https://learn.microsoft.com/en-us/azure/ai-services/openai/concepts/use-your-data?tabs=ai-search#storage-accounts

    If the issue persists, please let me know and we might need a deeper investigation to check on the issue further. Do let us know if you have any further queries. I’m happy to assist you further.

    Please do not forget to "Accept the answer” and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.