I can’t remove an internal user from Sharepoint access rights

Jeremie GLAIS 20 Reputation points
2024-06-19T15:52:48.5266667+00:00

Hello

,

I have a main site called "Intranet" which is itself divided into several "sub-sites" according to the service of my company.

Depending on the groups to which they belong, a user will see the "intranet/IT" or "intranet/accounting" site.

Everything works perfectly well except ONE thing. When I share a folder with my corporate user to an external user, I can then delete the sharing to that folder.

However, when I share my folder with a user of my company, I can no longer delete it, it is only with my administrator account that I can do it because it is the owner of the "intranet" site.

The box is greyed out and it is written: access is not available because you are not the owner of this item :

User's image

I put total control in the rights on the intranet/IT "sub-site" but I still cannot remove this access from my internal collaborator.

Would you have a lead please? I can’t add everyone owner otherwise they will see all "sub-sites" of my intranet site.

Thanks a lot !!!

JérémieG

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
10,279 questions
{count} votes

Accepted answer
  1. Haoyan Xue_MSFT 22,461 Reputation points Microsoft Vendor
    2024-06-20T07:54:51.0066667+00:00

    Hi @Jeremie GLAIS ,

    I apologize for misunderstanding your question.

    Thank you for your time and explaining it to me in detail.

    The settings in the previous answer are for external users, you're reporting an error because you can't remove permissions for internal users. Please check if you have Full control permissions for this file/folder/library. This is by design, only users with Full control can change the delete permission.

    When I grant full control permissions, the "access is not available because you are not the owner of this item" error does not appear.

    User's image


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


2 additional answers

Sort by: Most helpful
  1. Haoyan Xue_MSFT 22,461 Reputation points Microsoft Vendor
    2024-06-20T05:52:48.3666667+00:00

    Hi @Jeremie GLAIS ,

    Thank you for posting in this community.

    Here are steps to allow someone other than the site owner to edit the list of shared access permissions.

    1.In the "Intranet" main site, Settings->Site Permissions

    2.Change how members can share

    User's image

    3.Depending on your needs, choose the first or second option(You should now be the third option.).

    User's image

    Hope the information can help you. And if there have any unclear or misunderstanding, please feel free to post back and we’ll continue to help you all the time!


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Jeremie GLAIS 20 Reputation points
    2024-06-20T06:40:39.4133333+00:00

    Hi @Haoyan Xue_MSFT ,

    Thank's for your reponse ! But I checked and I have the second point that a user who can edit can share files.

    User's image

    This is not my problem, I can share with an internal and external user. I can remove the access I gave to an external user but not to an internal user, I had to be "owner of the site" to be able to perform this task as in my photo but if I am, I can see all the sub-sites of my intranet (IT, accounting etc...).

    User's image

    Even when I am in full control, I cannot remove access to this internal user but I can invite...

    Thanks again!

    JérémieG

    0 comments No comments