A RDS User is immediately signed out of the RDS server when logging in

Duncan Drury 25 Reputation points
2024-06-20T16:30:47.19+00:00

I am running a Remote Desktop Server in Windows 2019, and most users have no problem accessing it.

One user however, who is based in Turkey and accesses the RDS over VPN - as soon as they login to the server they see the logging in message, briefly they see their desktop then immediately see the signing out message. In the logs I can find the user has logged in, then there is a message saying:

Session 26 has been disconnected, reason code 12

I have tried deleting the user's profile from the server, but when they log back in exactly the same thing happens. When I login using their credentials from my computer the same thing happens. When I login using my credentials no problem at all. Since I am getting the issue locally to the computer, we have discounted the VPN as being an issue.

We created a brand new account in Active Directory for the user to try, and initially this worked, but subsequent logins the same thing started happening.

Any thoughts on where else I should be looking for error messages or potential fixes for this user's problem?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,609 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,393 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Karlie Weng 16,351 Reputation points Microsoft Vendor
    2024-06-24T07:44:43.69+00:00

    Hello,

    It's advisable to review your Group Policy for any boot scripts or other policies that may log off his user account, especially since he is at a different location.


    If the Answer is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments

  2. Stuart Bradford (Absoft) 0 Reputation points
    2024-07-03T15:01:02.0233333+00:00

    I am seeing the same issue with a single user being immediately signed out upon connection to any an RDS remoteApp.

    Specifically - under identical source conditions :

    • ProblemUser is able to successfully make an RDP connection to the RDS session host with mstsc.exe.
    • ProblemUser is unable to connect to any known-working RDS remoteApps
    • ProblemUser has been troubleshot to the point of complete recreation in AD - no change
    • new users created with identical process are able to successfully connect to the same RDS remoteapps.

    The log-on/log-off events look entirely as expected and there are no other event i can find of relevence.

    Given that the issue persists an entirely new user-object it does feel very GPO related but the same policies are applied to working users. There are no local rules/policies on either of the session hosts/RDgw that specifically target the ProblemUser that i can find.

    I could, of-course, create a new "ProblemUser2" account and have them use that going forward but this would constitute defeat!

    Anyone else battling this?

     

    0 comments No comments