VS 2022 Not showing red squiggles under errors when i debug projects saved on network disk

Willis1962 25 Reputation points

User's image

Microsoft Technologies based on the .NET software framework.
3,638 questions
An object-oriented and type-safe programming language that has its roots in the C family of languages and includes support for component-oriented programming.
10,640 questions
0 comments No comments
{count} vote

Accepted answer
  1. Frank636 95 Reputation points


    Instead of using the remote repository's shared network path (\\ComputerName...), give it a drive letter (Z:...) with File Explorer's "Map network drive.."

    The error squiggles, etc. go missing even if the project is on the local machine but the network path is used.


    2 people found this answer helpful.

2 additional answers

Sort by: Most helpful
  1. Jing Zhou 5,210 Reputation points Microsoft Vendor


    Thank you for posting in Q&A forum.

    Please try the following:

    1. Update your VS2022 to the latest version with Visual Studio Installer and launch it again.
    2. Enter “devenv /ResetSettings” at Developer Command Prompt for VS 2022 to restore your Visual Studio default setting.
    3. Close all running VS instances and delete the hidden .vs, bin and obj folders in the project folder.
    4. Rebuild the project.
    5. Create a new project and check that it works properly.
    6. Ensure you are using "Build + IntelliSense" in the Error List window.

    Best regards,

    Jill Zhou

    If the Answer is helpful, please click "Accept Answer" and upvote it

    1 person found this answer helpful.

  2. Jiale Xue - MSFT 43,046 Reputation points Microsoft Vendor

    Hi @Willis1962 , Welcome to Microsoft Q&A,

    Go to Tools->Options and turn on Show error squiggles.

    https://learn.microsoft.com/en-us/visualstudio/ide/find-and-fix-code-errors?view=vs-2022User's image

    Best Regards,


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".