Windows only appears to be using SOCKS4 proxy protocol, how do I enable SOCKS5?

Robin Bussell 0 Reputation points
2024-06-21T18:26:51.6666667+00:00

Hi all, here's a nice problem for you:

I have set up my win11 machine to use a socks proxy, via the old style internet options dialogue.

(internet options->connections->Lan settings->tick "use a proxy", hit advanced, clear all but the socks proxy settings)

For testing purposes I have removed the default gateway and left in only static routes to my proxy and to a DNS, via my default gateway. So I can be sure that only proxy traffic is being used.

It works ok for TCP but not UDP, on investigation it appears that windows is only using socks V4 protocol.

I have verified this by two methods: examining packets being sent via wireshark on the client machine when edge is used to load a page (only socks 4 commands are seen ) and by disabling socks v4 on the proxy server (web browsing stops working when socks 4 is disabled, and starts working again when it is re-enabled ). The proxy server is dante v1.4.2 running on ubuntu 22.04. No authentication is being used on the proxy server, simply IP address filtering.

Is there a setting somewhere in win 11 that might have disabled socks5?

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
5,039 questions
0 comments No comments
{count} votes