C++/CLI link error vs 2019: missing mscoree.lib when compiling for win arm64

Hichem 26 Reputation points
2020-11-23T13:59:38.377+00:00

Hello,

When trying to compile my C++/CLI project targetting ARM64, I'm getting the following error: LINK : fatal error LNK1104: cannot open file 'MSCOREE.lib'
I checked the library path, the project is trying to get this lib from: "C:\Program Files (x86)\Windows Kits\NETFXSDK\4.8\lib\um\arm64", but this path doesn't exist. I only have arm, x64 and x86. I tried to install other .Net FW SDK version (4.7.2, 4.7.1, 4.61) and all have the same problem.
Please can you tell me how can I have a good sdk with all architectures correctly installed?

C++
C++
A high-level, general-purpose programming language, created as an extension of the C programming language, that has object-oriented, generic, and functional features in addition to facilities for low-level memory manipulation.
3,523 questions
0 comments No comments
{count} vote

Accepted answer
  1. Jeanine Zhang-MSFT 9,101 Reputation points Microsoft Vendor
    2020-11-24T05:21:12.877+00:00

    Hi,

    The .NET Framework does not natively support ARM64 and there are no plans to add this support. Our recommendation is to consider moving up to .NET Core if you need ARM64 support.

    I suggest you could try to use .NET 5 to instead of .net framework.

    For more details I suggest you could refer to the links:
    https://devblogs.microsoft.com/dotnet/arm64-performance-in-net-5/
    https://learn.microsoft.com/en-us/dotnet/core/dotnet-five

    Best Regards,

    Jeanine


    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Hoàng ND 1 Reputation point
    2022-02-27T13:18:03.227+00:00

    Hi, can you give me details how to fix it ?

    0 comments No comments