Microsoft remote desktop is not working after Big Sur Update on Mac

Ayşe Gelal 0 Reputation points
2024-06-23T13:53:29.93+00:00

Can you help

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,391 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. mahdi najaf 0 Reputation points
    2024-06-23T14:20:19.32+00:00

    Hi Ayşe,

    Some users have experienced the same issue with Microsoft Remote Desktop not working after the macOS Big Sur update. Here are a few steps that helped me resolve the problem:

    Update Microsoft Remote Desktop:

    Make sure you have the latest version of Microsoft Remote Desktop from the Mac App Store. Sometimes, updates can fix compatibility issues.
    

    Reset Microsoft Remote Desktop Preferences:

    Open Finder.
    
    Go to ~/Library/Containers/com.microsoft.rdc.mac.
    
    Delete the folder com.microsoft.rdc.mac.
    

    Grant Full Disk Access:

    Go to System Preferences > Security & Privacy > Privacy tab.
    
    Select Full Disk Access from the left panel.
    
    Click the lock to make changes and add Microsoft Remote Desktop to the list.
    

    Check Network Settings:

    Ensure that your Mac's network settings haven't changed after the update.
    
    Verify that your VPN or firewall settings aren't blocking the remote desktop connection.
    

    Reinstall Microsoft Remote Desktop:

    Uninstall the current Microsoft Remote Desktop app.
    
    Download and install the latest version from the Mac App Store.
    

    If these steps don't resolve the issue, you might want to check for any known compatibility issues on Microsoft's support page.

    Hope this helps!

    Best, Mahdi

    0 comments No comments

  2. Karlie Weng 16,251 Reputation points Microsoft Vendor
    2024-06-25T06:06:55.9333333+00:00

    Hello,

    To update your Remote Desktop to the latest version, navigate to Microsoft Remote Desktop, then go to Preferences and select the General tab. Here, uncheck "Use system proxy configurations" and also uncheck "Use hardware acceleration."


    If the Answer is helpful, please click Accept Answer and upvote it.

    0 comments No comments