Microsoft Azure Portal Error: no_tokens_found

Lucas Pierce 10 Reputation points
2024-06-25T00:24:08.6533333+00:00

I'm not super tech savvy so please bare with me. Whenever I log into MS (Microsoft) Azure I'm greeted with a lovey message I cannot stand.

Interaction Require

The portal encounter an issue while attempting to retrieve access tokens. We suggest attempting to sign in again, or alternatively, continuing without access tokens, although this may result in a suboptimal user experience. Additional details: no_tokens_found: No refresh token found in the cache. Please sign-in...

Sign In again Ignore

Clicking Sign In again refreshes the page around 10-20 times within 2-3 seconds and greets me with the same message.

Clicking Ignore sends me to a page stating "Session expired."

I've cleared my caches, tried different browsers, even a different account. Still the same message

From my understanding there is a Azure support tab somewhere in the Dashboard, however this message prevents me from entering the portal at all. The normal tech support for MS was no help troubleshooting the issue.

This is super time sensitive because it is for my schooling and I need this for a project. Anything helps at all and I hope someone can help me resolve this issue.

Azure Cost Management
Azure Cost Management
A Microsoft offering that enables tracking of cloud usage and expenditures for Azure and other cloud providers.
2,341 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. edouard.jubert 5 Reputation points
    2024-07-16T10:05:35.58+00:00

    Hi,
    I just encountered the same problem.

    It turns out it was that my system clock was unsynced (it was 9:00AM instead of 11:00AM).

    So I just sync and restart my browser then I was able to login.

    I hope this fix your problem

    1 person found this answer helpful.

  2. Abdul 2,510 Reputation points Microsoft Vendor
    2024-07-19T05:02:09.5633333+00:00

    Hi @Lucas Pierce,

    Thank you for reaching out of Q&A forum.

    It appears you’re experiencing a common issue with the Azure portal, where it’s unable to retrieve access tokens, often due to a missing refresh token in the cache. Here are a few steps you can try to resolve this issue.

    Could you do a simple thing please?

    • Clear the browser Cookies & Data OR use a Private Window.
    • Go to your system clock settings and press sync to ensure the time is accurate. An incorrect system time can interfere with token retrieval.
    • Try logging in through this portal URL: portal.azure.com/<tenant-ID> If it's helpful, please consider clicking "Upvote and Accept Answer" on the post to let us know. If you encounter any further issues, feel free to ask for additional assistance!