Azure WebApp (New Region) Deployment

Jomel P 0 Reputation points
2024-06-25T09:03:57.7133333+00:00

Hi,

I have been deploying my node.js web application to Azure Web App via local git for months without incident.

I created a new Azure Web App service in another region (other settings are the same) to deploy my app. I'm doing the same process:

  1. Open VS Code
  2. Open Azure extension
  3. Open App Services
  4. Go to the new Web App
  5. Deploy to Web App

With Local Git as source, I always get the error "Failed to get status of deployment", tried multiple times.

In the VC Code output panel it only shows 3 lines:

   Starting deployment...

   Deploying Local Git repository to "*******"...

   Error: Failed to get status of deployment.

When I used "none" as the deployment source, it worked.

What could be the cause of this error? Where can I see details of the deployment logs?

Thanks!

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,339 questions
{count} votes

1 answer

Sort by: Most helpful
  1. ajkuma 24,661 Reputation points Microsoft Employee
    2024-06-28T17:29:55.7266667+00:00

    Jomel P, Firstly, apologies for the delayed response. Are you provisioning Windows or Linux ASP? Which region are you attempting to deploy?

    It's good to hear that deploying with 'none' as the deployment source worked for your Azure Web App. Since the deployment succeeds with 'none' as the source, it suggests that the Azure Web App service itself is functioning correctly in the new region, and the problem is most likely isolated to the Local Git deployment method.

    If you haven't done this already, to further isolate the issue:

    • Ensure that the Local Git repository is correctly configured for the new Azure Web App service. (double check - the Git remote settings in your local repository to ensure they point to the correct URL of the new Azure Web App and also the credentials).
    • To isolate the issue, you may leverage App Service diagnostics from Azure Portal> Navigate to your App Service app in the Azure Portal. -In the left navigation, click on Diagnose and solve problems - Review -deployment failure/event diag options.' (screenshot)
    • Enable and review logs to fetch more details about the error: #enable-application-logging-linuxcontainer and Access log files

    User's image

    Kindly let us know how it goes, I'll follow-up with you further.


    If the answer helped (pointed, you in the right direction) > please click Accept Answer - it will benefit community members to find the answers quickly.

    0 comments No comments